s3 client put_bucket_lifecycle_configuration in govcloud : S3 API MD5 error Fix #4515
Replies: 1 comment
|
This distinction is important: So I would avoid marking That information can distinguish a stale SDK model from an endpoint-specific requirement. A boto3-only documentation change could otherwise incorrectly describe the public API for regions/endpoints where the parameter is optional. |
Uh oh!
There was an error while loading. Please reload this page.
Note that if you are using s3.put_bucket_lifecycle_configuration in govcloud you will likely receive the error "Missing required header for this request: Content-MD5"
This is because the S3 GovCloud endpoints enforce this header but the Boto3 client does not provide it , possibly because MD5 is disabled on a FIPS compliant server.
The solution is to add ChecksumAlgorithm='SHA256' to your request. This should be marked as a required parameter - but I think that is a change that would have to be made by the S3 API team as the boto documentation is generated.
All reactions